Cannot send External Email (Full Version)

All Forums >> [Microsoft Exchange 2003] >> Exchange 2003 SBS



Message


AndyWhy -> Cannot send External Email (31.Dec.2013 5:24:06 AM)

Hi folks, I hope some of you can help me, as I'm at the end of my tether! A friend of mine asked me to 'tidy up' his SBS 2003 server as he'd set it up 3 years ago and not really touched it since. The main item on his list was getting Exchange set up correctly. When I first arrived they could send and receive internal email, send email externally, but not receive it. That was an easy fix as they had no Exchange MX records setup and once I'd finished that it worked correctly. We had some issues with our domain provider last week and we stopped receiving emails for a few days, but this was resolved as of Monday.

However... now when we try to send external emails, from any of our Exchange accounts, we get a message saying either-

Your message did not reach some or all of the intended recipients.

Subject: Test
Sent: 31/12/2013 10:45

The following recipient(s) could not be reached:

andy@gmail.com on 31/12/2013 10:45
The e-mail account does not exist at the organization this message was sent to. Check the e-mail address, or contact the recipient directly to find out the correct address.
<roselodge.co.uk #5.1.1>


Or -

Your message did not reach some or all of the intended recipients.

Subject:
Sent: 30/12/2013 15:02

The following recipient(s) could not be reached:

andy@gmail.com on 30/12/2013 15:02
You do not have permission to send to this recipient. For assistance, contact your system administrator.
<roselodge.co.uk #5.7.1 smtp;550 5.7.1 Unable to relay for andy@gmail.com>



Now this has been tested on several different webmail addresses and the result is always one of these two. These are confirmed email addresses that were working through our Exchange accounts last week.

Now, other that installing .net 4.0, nothing has changed on our server and I have no idea why this has just started happening. I've used telnet to check port 25 and it seems fine. Also, when I tried to turn logging on I found that we had no virtual SMTP connector and any attempt I've made to add it has not worked. I also attempted to set things up with the Internet Mail Wizard I was told that our server is already setup as a bridgehead.

I would honestly prefer to re-install this server from scratch, but that's sadly not an option. Any ideas?




Gulab -> RE: Cannot send External Email (31.Dec.2013 6:09:11 AM)

Check Firewall if you have exchange server IP added in firewall so that it can send email outside.
Are you using Smart Host or DNS to send email outside?




AndyWhy -> RE: Cannot send External Email (31.Dec.2013 7:03:40 AM)

I've tried disabling the firewall, but I still got the same error. And we're using DNS. Thanks!




Gulab -> RE: Cannot send External Email (31.Dec.2013 7:39:29 AM)

Which FireWall you are talking about? Is the Windows FireWall or External Firewll.




AndyWhy -> RE: Cannot send External Email (31.Dec.2013 7:52:29 AM)

I was talking about Windows Firewall, but I've disabled our external firewall and tested that too but still have the same issues. Thanks!




Gulab -> RE: Cannot send External Email (31.Dec.2013 7:57:52 AM)

Are you able to send email via Telnet?
Were you able to send email outside before?




AndyWhy -> RE: Cannot send External Email (31.Dec.2013 8:07:57 AM)

I've only tried to send internally through telnet, but that works fine. It was working before. I've made no changes since then other that installing .NET 4.0 on the server and I don't think it would have any effect.




Gulab -> RE: Cannot send External Email (31.Dec.2013 8:25:52 AM)

If you are able to send email using Telnet that means it's Firewall issue (Most of my cases)
Why would you install .net 4.0 for SBS 2003?




AndyWhy -> RE: Cannot send External Email (31.Dec.2013 8:36:58 AM)

Even if I'm just sending it internally? The internal emails have always worked fine. And .Net was a requirement for the backup software we were installing (which turned out to be incompatible with SBS 2003 anyway).




Gulab -> RE: Cannot send External Email (31.Dec.2013 8:42:32 AM)

Did you perform the action as per my previous post?
I hope you removed the .net 4.0.




AndyWhy -> RE: Cannot send External Email (31.Dec.2013 8:45:04 AM)

Ok, I just checked telnet again and its saying that the email address I use, name@roselodge.co.uk is an invalid address. Why would that be?




AndyWhy -> RE: Cannot send External Email (31.Dec.2013 8:47:02 AM)

I did remove .NET 4.0. I've tried (or re-tried) everything you've suggested. Telnet now appears to be falling over when I try to enter the FROM email address. Thanks again for all your help.




Gulab -> RE: Cannot send External Email (31.Dec.2013 9:49:14 AM)

Post the error you are getting in Telnet.
Do you have any antivirus installed on the server?




AndyWhy -> RE: Cannot send External Email (1.Jan.2014 6:53:35 AM)

I'm not in again until tomorrow. I'll post the telnet message then. Thanks.




AndyWhy -> RE: Cannot send External Email (2.Jan.2014 4:58:13 AM)

Ok, the two telnet errors I'm getting are

501 5.5.4 Invalid Address and 550 5.7.1 Unable to relay for mail@hotmail.com

We do have virus software and I've just discovered that it's not working correctly, so I'm looking at that now.

I tried changing my FQDN (based on other advice on that telnet error) by changing my machine name to our domain name, www.roselodge.co.uk. When I rebooted it came up as Our-Server.www.roselodge.co.uk. Is that how it should look? Thanks!




Gulab -> RE: Cannot send External Email (2.Jan.2014 5:03:07 AM)

quote:

501 5.5.4 Invalid Address and 550 5.7.1 Unable to relay

Check this out and let me know if it helps
https://confluence.atlassian.com/display/CONFKB/550+5.7.1+Unable+to+Relay+Mail+From+Exchange+Server




AndyWhy -> RE: Cannot send External Email (2.Jan.2014 5:31:33 AM)

Thanks, but I'm still having the same issue.




AndyWhy -> RE: Cannot send External Email (2.Jan.2014 5:46:52 AM)

What is odd is that any messages I try to send externally don't seem to be appearing in the logging file at all. Would that indicate anything?




AndyWhy -> RE: Cannot send External Email (3.Jan.2014 6:19:06 AM)

Got this sorted now thanks. It looks like my SMTP connector was pointed to my internal mail server as a smart host which was causing the email to just bounce around on the server for a while. Thanks for all the help Gulab!




Gulab -> RE: Cannot send External Email (3.Jan.2014 6:49:29 AM)

Good to hear issue is resolved.




Page: [1]