• RSS
  • Twitter
  • FaceBook

Exchange Server Forums

Forums | Register | Login | My Profile | Inbox | RSS RSS icon | My Subscription | My Forums | Address Book | Member List | Search | FAQ | Ticket List | Log Out

Autodiscover service is setting the wrong server name for non-Outlook clients (i.e. Exchange ActiveS

Users viewing this topic: none

Logged in as: Guest
  Printable Version
All Forums >> [Microsoft Exchange 2013] >> Mobility >> Autodiscover service is setting the wrong server name for non-Outlook clients (i.e. Exchange ActiveS Page: [1]
Login
Message << Older Topic   Newer Topic >>
Autodiscover service is setting the wrong server name f... - 19.Mar.2014 2:47:52 AM   
krehan

 

Posts: 13
Joined: 4.Mar.2010
From: Saudi Arabia
Status: offline
Autodiscover service is setting the wrong server name for non-Outlook clients (i.e. Exchange ActiveSync, iOS, Android, etc.)

Dears,

We just implemented autodiscover for our Exchange 2013 server, and it it almost working properly except for the fact that the autodiscover settings being pushed to the clients set the server name at the root domain name (i.e. SERVER = domainname.com) instead of the FQDN of the expected server name (i.e. SERVER = server.domainname.com).

Exactly after configuring GOdaddy and my local DNS server for Autodiscover, I got this issue:
I can't Configure user in the local domain (joined to domain as usual), and I'm getting Microsoft Exchange server is unavailable.
I can't use ActiveSync from any local/external workstation. EAS: The Server cannot found.


The UCC SSL certificate applied to the Exchange Server works fine and has both autodiscover.domainname.com and server.domainname.com as acceptable entries, so I'm assuming that there's something not set quite right on the Exchange Server side.

What should I check to make sure that the autoconfigure.xml file is giving out 'server.domainname.com' to all OutlookAnywhere and Exchange ActiveSync autodiscover clients?

[PS] C:\Windows\system32>Get-MailboxDatabase | select name,rpcclientaccessserver | ft -auto

Name RpcClientAccessServer
---- ---------------------
Mailbox Database 208659569 IMA95.imagroup.com
Mailbox Database 104236107 IMA95.imagroup.com

Regards,

Khalid Rehan.

_____________________________

--
Khalid Rehan
System Administration.
Redhat RHCSA Certified.
Post #: 1
RE: Autodiscover service is setting the wrong server na... - 25.Mar.2014 12:02:26 PM   
krehan

 

Posts: 13
Joined: 4.Mar.2010
From: Saudi Arabia
Status: offline
Any help?

_____________________________

--
Khalid Rehan
System Administration.
Redhat RHCSA Certified.

(in reply to krehan)
Post #: 2
RE: Autodiscover service is setting the wrong server na... - 5.Apr.2014 12:23:57 AM   
krehan

 

Posts: 13
Joined: 4.Mar.2010
From: Saudi Arabia
Status: offline
Is it related to the server certificate?

_____________________________

--
Khalid Rehan
System Administration.
Redhat RHCSA Certified.

(in reply to krehan)
Post #: 3
RE: Autodiscover service is setting the wrong server na... - 17.Apr.2019 2:38:56 PM   
Edwin009

 

Posts: 19
Joined: 4.Mar.2016
Status: offline
Verify the Autodiscover URL by running below command using Exchange PowerShell:
Get-ClientAccessServer | FL AutoDiscoverServiceInternalUri


Then use below command to set the Correct Autodiscover.

Set-ClientAccessServer -Identity "MBX-01" -AutoDiscoverServiceInternalUri "https://autodiscover.contoso.com/autodiscover/autodiscover.xml" -AutoDiscoverSiteScope "Mail"

https://docs.microsoft.com/en-us/powershell/module/exchange/client-access-servers/set-clientaccessserver?view=exchange-ps

Regards,
Ed |Tech Support Team
https://www.Apps4rent.com/

(in reply to krehan)
Post #: 4

Page:   [1] << Older Topic    Newer Topic >>
All Forums >> [Microsoft Exchange 2013] >> Mobility >> Autodiscover service is setting the wrong server name for non-Outlook clients (i.e. Exchange ActiveS Page: [1]
Jump to:

New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Follow TechGenix on Twitter