Autodiscover service is setting the wrong server name for non-Outlook clients (i.e. Exchange ActiveS (Full Version)

All Forums >> [Microsoft Exchange 2013] >> Mobility



Message


krehan -> Autodiscover service is setting the wrong server name for non-Outlook clients (i.e. Exchange ActiveS (19.Mar.2014 2:47:52 AM)

Autodiscover service is setting the wrong server name for non-Outlook clients (i.e. Exchange ActiveSync, iOS, Android, etc.)

Dears,

We just implemented autodiscover for our Exchange 2013 server, and it it almost working properly except for the fact that the autodiscover settings being pushed to the clients set the server name at the root domain name (i.e. SERVER = domainname.com) instead of the FQDN of the expected server name (i.e. SERVER = server.domainname.com).

Exactly after configuring GOdaddy and my local DNS server for Autodiscover, I got this issue:
I can't Configure user in the local domain (joined to domain as usual), and I'm getting Microsoft Exchange server is unavailable.
I can't use ActiveSync from any local/external workstation. EAS: The Server cannot found.


The UCC SSL certificate applied to the Exchange Server works fine and has both autodiscover.domainname.com and server.domainname.com as acceptable entries, so I'm assuming that there's something not set quite right on the Exchange Server side.

What should I check to make sure that the autoconfigure.xml file is giving out 'server.domainname.com' to all OutlookAnywhere and Exchange ActiveSync autodiscover clients?

[PS] C:\Windows\system32>Get-MailboxDatabase | select name,rpcclientaccessserver | ft -auto

Name RpcClientAccessServer
---- ---------------------
Mailbox Database 208659569 IMA95.imagroup.com
Mailbox Database 104236107 IMA95.imagroup.com

Regards,

Khalid Rehan.




krehan -> RE: Autodiscover service is setting the wrong server name for non-Outlook clients (i.e. Exchange ActiveS (25.Mar.2014 12:02:26 PM)

Any help?




krehan -> RE: Autodiscover service is setting the wrong server name for non-Outlook clients (i.e. Exchange ActiveS (5.Apr.2014 12:23:57 AM)

Is it related to the server certificate?




Edwin009 -> RE: Autodiscover service is setting the wrong server name for non-Outlook clients (i.e. Exchange ActiveS (17.Apr.2019 2:38:56 PM)

Verify the Autodiscover URL by running below command using Exchange PowerShell:
Get-ClientAccessServer | FL AutoDiscoverServiceInternalUri


Then use below command to set the Correct Autodiscover.

Set-ClientAccessServer -Identity "MBX-01" -AutoDiscoverServiceInternalUri "https://autodiscover.contoso.com/autodiscover/autodiscover.xml" -AutoDiscoverSiteScope "Mail"

https://docs.microsoft.com/en-us/powershell/module/exchange/client-access-servers/set-clientaccessserver?view=exchange-ps

Regards,
Ed |Tech Support Team
https://www.Apps4rent.com/




Page: [1]