• RSS
  • Twitter
  • FaceBook

Exchange Server Forums

Forums | Register | Login | My Profile | Inbox | RSS RSS icon | My Subscription | My Forums | Address Book | Member List | Search | FAQ | Ticket List | Log Out

Synchronization error between HUB and EDGE, The LDAP server is unavailable

Users viewing this topic: none

Logged in as: Guest
  Printable Version
All Forums >> [Microsoft Exchange 2010] >> General >> Synchronization error between HUB and EDGE, The LDAP server is unavailable Page: [1]
Login
Message << Older Topic   Newer Topic >>
Synchronization error between HUB and EDGE, The LDAP se... - 13.Aug.2014 12:37:11 PM   
Rodya4

 

Posts: 2
Joined: 13.Aug.2014
Status: offline
Good morning friends,

Back in Abril, we had an issue that caused our Edge server to fail. When we try to resynchronize the subscription between Hub and Edge, we get the next generic error when using 'Start-EdgeSynchronization', "The LDAP server is unavailable". A 1024 topology event is raised "Failed to connect to the Edge Transport server ADAM instance with exception The LDAP server is unavailable".

What we have done so far:

- Tried to re-subscribe several times.

- Recheck connection errors between servers although we didn’t modify our network infrastructure. 'Telnet' HUB to EDGE at port 25 and viceversa OK. 'Telnet' HUB to Edge at ADAM port 50636 OK. We also tried to subscribe permitting all IP traffic at our DMZ firewall.

- FQDN and Netbios resolution between EDGE and HUB is working fine using an entry on the 'Host' file at both servers. And there is also a manually created 'Host A' registry in our Domain DNS zone for the Edge.

- Restart of services involved in the process: 'topology' on the HUB, 'ADAM' on the EDGE, for example. Anyway, we ended restarting both machines several times and try the re-subscription then, no luck.

- Reinstall the EDGE server entirely, changing his original IP and his NetBIOS name. Both Edge and Hub have the same Exchange updates.

- Renew all certificates in the EDGE and at the HUB. The certs are self-signed, so http://technet.microsoft.com/en-us/library/cc671171%28v=EXCHG.80%29.aspx (same cert in edge and HUB) is not the case.

This case is in hands of Microsoft since April; one of those situations that makes you feel that you are no longer an administrator, just an operator that deals with Microsoft… They tried some undocumented operations, like network monitor, disable recipients, or erase it with ‘Adsiedit’, but with no luck.

I suspect that there is a bug that caused the HUB to be stuck remembering the old failed EDGE subscription...

Any help would be incredibly helpful for me. Thanks in advance!
Post #: 1
RE: Synchronization error between HUB and EDGE, The LDA... - 13.Aug.2014 1:53:28 PM   
de.blackman

 

Posts: 3542
Joined: 4.Apr.2005
From: Toronto, Canada
Status: offline
Can you confirm that you are able to ping both NetBIOS and FQDN of the edge from the hub transport and vice versa? What errors do you see in the application logs of both servers when you try to run the subscription?

_____________________________

Ibrahim Benna - Microsoft Exchange MVP
Forum Moderator
Navantis
@IbrahimBenna

(in reply to Rodya4)
Post #: 2
RE: Synchronization error between HUB and EDGE, The LDA... - 13.Aug.2014 5:04:59 PM   
Rodya4

 

Posts: 2
Joined: 13.Aug.2014
Status: offline
quote:

ORIGINAL: de.blackman

Can you confirm that you are able to ping both NetBIOS and FQDN of the edge from the hub transport and vice versa? What errors do you see in the application logs of both servers when you try to run the subscription?


Thanks de.blackman for your response.

Yes, I can confirm that I can resolve netbios and FQDN. There is an entry on the host file of both servers. And a DNS sufix for the EDGE (is on a workgroup, of course, not in the domain).

When running star-edgesyncronization we get the event 1024 topology "Failed to connect to the Edge Transport server ADAM instance with exception The LDAP server is unavailable" on the hub. Nothing on the edge.

Regards.

(in reply to de.blackman)
Post #: 3
RE: Synchronization error between HUB and EDGE, The LDA... - 14.Aug.2014 11:21:46 AM   
de.blackman

 

Posts: 3542
Joined: 4.Apr.2005
From: Toronto, Canada
Status: offline
Running start-edgesynchronization wont work unless you actually have a proper subscription in the site the hub transport server is in. If a subscription exists, remove and try creating a new one and add it.

_____________________________

Ibrahim Benna - Microsoft Exchange MVP
Forum Moderator
Navantis
@IbrahimBenna

(in reply to Rodya4)
Post #: 4

Page:   [1] << Older Topic    Newer Topic >>
All Forums >> [Microsoft Exchange 2010] >> General >> Synchronization error between HUB and EDGE, The LDAP server is unavailable Page: [1]
Jump to:

New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Follow TechGenix on Twitter