Cross Forest Migration Batch Failed (Full Version)

All Forums >> [Microsoft Exchange 2013] >> Migration



Message


doohder -> Cross Forest Migration Batch Failed (19.Feb.2015 3:13:13 PM)

I'm trying to run a cross forest migration batch. I've ran the prepare-moverequest.ps1 and then ADMT the account over to the new forest. I then proceed to start the batch it fails with a very generic error after maybe 20 seconds.One thing I should mention is this from Exchange 2013 CU7 to Exchange 2013 CU7. i have been able to get this to work prior to cu 7.

Get-MigrationBatch -Diagnostic | fl

[PS] D:\TEMP>Get-MigrationBatch -Diagnostic | fl


RunspaceId : d8eea5cc-9eca-438e-8007-599978fd84a4
Identity : migration
Status : Failed
BatchGuid : 0e280188-7403-4b53-b1bf-34f62a5bec1e
TotalCount : 1
ActiveCount : 0
StoppedCount : 0
SyncedCount : 0
FinalizedCount : 0
FailedCount : 0
FailedInitialSyncCount : 0
FailedIncrementalSyncCount : 0
PendingCount : 1
ProvisionedCount : 0
ValidationWarningCount : 0
ValidationWarnings : {}
Message : An unknown error occurred while processing this migration batch.
CreationDateTime : 2/19/2015 7:44:03 PM
CreationDateTimeUTC : 2/19/2015 7:44:03 PM
StartDateTime : 2/19/2015 7:44:03 PM
StartDateTimeUTC : 2/19/2015 7:44:03 PM
InitialSyncDateTime :
InitialSyncDateTimeUTC :
InitialSyncDuration :
LastSyncedDateTime :
LastSyncedDateTimeUTC :
FinalizedDateTime :
FinalizedDateTimeUTC :
SubmittedByUser :
OwnerId : /Users/Batch Admin
OwnerExchangeObjectId : 65208ace-1ea6-4599-a4ca-6d4b509dea90
NotificationEmails : {temp.user}

ExcludedFolders : {}
MigrationType : ExchangeRemoteMove
BatchDirection : Onboarding
Locale : en-US
Reports : {}
IsProvisioning : False
BatchFlags : DisallowExistingUsers, UseAdvancedValidation
AutoRetryCount : 0
CurrentRetryCount : 0
AllowUnknownColumnsInCsv : False
DiagnosticInfo : <MigrationJob name="migration">
<migrationJobType>ExchangeRemoteMove</migrationJobType>
<id>0e280188-7403-4b53-b1bf-34f62a5bec1e</id>
<MigrationStatusData>
<state>Active</state>
<status>Failed</status>
<stateLastUpdated>2/19/2015 7:44:46 PM</stateLastUpdated>
<previousStatus>SyncInitializing</previousStatus>
<error>An unknown error occurred while processing this migration batch.</error>
<transientErrorCount>0</transientErrorCount>
<SameStatusCount>1</SameStatusCount>
<internalError> at
Microsoft.Exchange.Migration.MigrationStatusData`1.SetFailedStatus(TStatus failureStatus,
Exception exception, String internalError, Nullable`1 state) at
Microsoft.Exchange.Migration.MigrationJob.SetFailedStatus(IMigrationDataProvider
provider, Exception exception) at Microsoft.Exchange.Migration.LegacyMigrationProcessor
.RunJobOperation(IMigrationDataProvider dataProvider, MigrationSession session,
MigrationJob job, Func`4 jobOperation) at
Microsoft.Exchange.Migration.LegacyMigrationProcessor.ProcessSession(MigrationSession
session, IMigrationDataProvider dataProvider) at
Microsoft.Exchange.Migration.MigrationScheduler.ProcessCacheEntry(MigrationCacheEntry
cacheEntry) at
Microsoft.Exchange.Migration.MigrationScheduler.Process(IMigrationJobCache cache) at
Microsoft.Exchange.Migration.MigrationApplication.Process() at
Microsoft.Exchange.Servicelets.SyncMigration.SyncMigrationServicelet.Work() at
System.Threading.ExecutionContext.RunInternal(ExecutionContext executionContext,
ContextCallback callback, Object state, Boolean preserveSyncCtx) at
System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback
callback, Object state, Boolean preserveSyncCtx) at
System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback
callback, Object state) at System.Threading.ThreadHelper.ThreadStart() | at Microsoft.
Exchange.Data.Storage.Management.MigrationPermanentException..ctor(LocalizedString
localizedErrorMessage) at
Microsoft.Exchange.Migration.MigrationPoisonCountThresholdExceededException..ctor() at Mi
crosoft.Exchange.Migration.LegacyMigrationProcessor.RunJobOperation(IMigrationDataProvider
dataProvider, MigrationSession session, MigrationJob job, Func`4 jobOperation) at
Microsoft.Exchange.Migration.LegacyMigrationProcessor.ProcessSession(MigrationSession
session, IMigrationDataProvider dataProvider) at
Microsoft.Exchange.Migration.MigrationScheduler.ProcessCacheEntry(MigrationCacheEntry
cacheEntry) at
Microsoft.Exchange.Migration.MigrationScheduler.Process(IMigrationJobCache cache) at
Microsoft.Exchange.Migration.MigrationApplication.Process() at
Microsoft.Exchange.Servicelets.SyncMigration.SyncMigrationServicelet.Work() at
System.Threading.ExecutionContext.RunInternal(ExecutionContext executionContext,
ContextCallback callback, Object state, Boolean preserveSyncCtx) at
System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback
callback, Object state, Boolean preserveSyncCtx) at
System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback
callback, Object state) at System.Threading.ThreadHelper.ThreadStart()
_Microsoft.Exchange.Migration.MigrationPoisonCountThresholdExceededException_An unknown
error occurred while processing this migration batch._|</internalError>
<internalErrorTime>2/19/2015 7:44:46 PM</internalErrorTime>
<statusHistory>0:0;1:43;</statusHistory>
<watsonHash>80b3</watsonHash>
<FailureRecord>
<FailureRecord>
<TimeStamp>2015-02-19T19:44:46.4941079Z</TimeStamp>
<DataContext></DataContext>
<ExceptionTypes>Exchange</ExceptionTypes>
<FailureType>MigrationPoisonCountThresholdExceededException</FailureType>
<FailureSide />
<FailureCode>-2146233088</FailureCode>
<MapiLowLevelError>0</MapiLowLevelError>
<Message>An unknown error occurred while processing this migration
batch.</Message>
<StackTrace> at Microsoft.Exchange.Data.Storage.Management.MigrationPermanentExc
eption..ctor(LocalizedString localizedErrorMessage)
at Microsoft.Exchange.Migration.MigrationPoisonCountThresholdExceededException..ctor()
at Microsoft.Exchange.Migration.LegacyMigrationProcessor.RunJobOperation(IMigrationData
Provider dataProvider, MigrationSession session, MigrationJob job, Func`4 jobOperation)
at
Microsoft.Exchange.Migration.LegacyMigrationProcessor.ProcessSession(MigrationSession
session, IMigrationDataProvider dataProvider)
at
Microsoft.Exchange.Migration.MigrationScheduler.ProcessCacheEntry(MigrationCacheEntry
cacheEntry)
at Microsoft.Exchange.Migration.MigrationScheduler.Process(IMigrationJobCache cache)
at Microsoft.Exchange.Migration.MigrationApplication.Process()
at Microsoft.Exchange.Servicelets.SyncMigration.SyncMigrationServicelet.Work()
at System.Threading.ExecutionContext.RunInternal(ExecutionContext executionContext,
ContextCallback callback, Object state, Boolean preserveSyncCtx)
at System.Threading.ExecutionContext.Run(ExecutionContext executionContext,
ContextCallback callback, Object state, Boolean preserveSyncCtx)
at System.Threading.ExecutionContext.Run(ExecutionContext executionContext,
ContextCallback callback, Object state)
at System.Threading.ThreadHelper.ThreadStart()
</StackTrace>
</FailureRecord>
</FailureRecord>
</MigrationStatusData>
<messageId>RgAAAADXqib5xHXWTbElkqmCDVnUBwBuGwJ5/Y49RbXeqxEWNmPfAAAAAAEUAABuGwJ5/Y49RbXeq
xEWNmPfAADFyQqhAAAJ</messageId>
<cancelled>false</cancelled>
<JobCancellationStatus>NotCancelled</JobCancellationStatus>
<orginallyCreated>2/19/2015 7:44:03 PM</orginallyCreated>
<started>2/19/2015 7:44:03 PM</started>
<restarted>2/19/2015 7:44:03 PM</restarted>
<finalized />
<isStaged>true</isStaged>
<poisonCount>5</poisonCount>
<batchFlags>DisallowExistingUsers, UseAdvancedValidation</batchFlags>
<totalRowCount>1</totalRowCount>
<cachedCounts>
<MigrationCountCache />
</cachedCounts>
<fullScanTime>2/19/2015 7:44:03 PM</fullScanTime>
<lastProcessedRowIndex></lastProcessedRowIndex>
<submittedBy></submittedBy>
<timeZone>Time zone: Id=tzone://Microsoft/Utc; DisplayName=UTC</timeZone>
<adminCulture>en-US</adminCulture>
<notificationEmails>user@abc.com</notificationEmails>
<direction>Onboarding</direction>
<targetDomainName>ForestWideOrganization</targetDomainName>
<skipSteps>None</skipSteps>
<SourceEndpoint>
<MigrationEndpoint>
<Type>ExchangeRemoteMove</Type>
<Name>mail</Name>
<GUID>406f7fae-af44-4f90-b6ee-4ababdfdb54a</GUID>
<LastModifiedTime>2/19/2015 7:39:42 PM</LastModifiedTime>
<RemoteServer>mail.abc.com</RemoteServer>
<SlotProvider>
<MaximumConcurrentMigrations>20</MaximumConcurrentMigrations>
<MaximumConcurrentIncrementalSyncs>15</MaximumConcurrentIncrementalSyncs>
<MigrationCountCache />
</SlotProvider>
<version>5</version>
<created>2/19/2015 7:39:42 PM</created>
<reportGuid>00000000-0000-0000-0000-000000000000</reportGuid>
<AuthenticationMethod>0</AuthenticationMethod>
<Domain>cpd_01</Domain>
<EncryptedPassword>hmtTuf3kiXIgpKvK78A02jwxWE4SIHBiVcgBOQQGmeFTJPe9i25aOaG4zspqC3eP<
/EncryptedPassword>
<Username>batchadmin</Username>
</MigrationEndpoint>
</SourceEndpoint>
<SubscriptionSettings>
<SubscriptionSettings />
</SubscriptionSettings>
<version>4</version>
<created>2/19/2015 7:44:03 PM</created>
<reportGuid>00000000-0000-0000-0000-000000000000</reportGuid>
<AllowUnknownColumnsInCsv>false</AllowUnknownColumnsInCsv>
<AsyncNotificationId>0e280188-7403-4b53-b1bf-34f62a5bec1e</AsyncNotificationId>
<AutoRunCount>0</AutoRunCount>
<BatchInputId>2c2d7230-a453-495f-9dce-524120067a5d</BatchInputId>
<BatchLastUpdated>2/19/2015 7:44:03 PM</BatchLastUpdated>
<MaxAutoRunCount>0</MaxAutoRunCount>
<MigrationBatchFlags>5</MigrationBatchFlags>
<OriginalJobId />
<TargetDomainName>ForestWideOrganization</TargetDomainName>
<ValidationWarningCount>0</ValidationWarningCount>
</MigrationJob>
SupportedActions : Start, Set, Remove
SourceEndpoint : mail
TargetEndpoint :
SourcePublicFolderDatabase :
TargetDatabases : {DB01, DB02, DB03, DB04, DB05}
TargetArchiveDatabases : {ARCDB01, ARCDB02, ARCDB03, ARCDB04, ARCDB05}
BadItemLimit : 10
LargeItemLimit : 0
PrimaryOnly : False
ArchiveOnly : False
TargetDeliveryDomain : abc.com
SkipSteps : None
Report :
StartAfter :
StartAfterUTC :
CompleteAfter :
CompleteAfterUTC :
IsValid : True
ObjectState : Unchanged

I found this forum with a similar error but trying different users or browsers did not fix my issue.

http://community.office365.com/en-us/f/156/t/236291.aspx

I've also tested the endpoints.

[PS] D:\TEMP>Test-MigrationServerAvailability -ExchangeRemoteMove -Autodiscover -EmailAddress user@abc.com -Cr
edentials $Credentials


RunspaceId : d8eea5cc-9eca-438e-8007-599978fd84a4
Result : Success
Message :
ConnectionSettings : <ExchangeConnectionSettings HasAdminPrivilege="True" HasAutodiscovery="False" HasMrsProxy="True"
AutodiscoverUrl="" IncomingEmailAddress="" IncomingRPCProxyServer="mail.abc.com"
IncomingExchangeServer="mail.abc.com" IncomingNSPIServer="" IncomingDomain="domain"
IncomingUserName="User"
EncryptedIncomingPassword="AbyFM96ZOVbEJjCuMu/mvFShsOL5G8f3XGwGNeMxO9oS/6UaCalH8rC47nfMcf9o"
IncomingAuthentication="Basic" ServerVersion="" TargetDomainName="" SourceMailboxLegDn=""
PublicFolderDatabaseServerLegacyDN="" />
SupportsCutover : False
ErrorDetail :
IsValid : True
Identity :
ObjectState : New

I've have done cross forest mailbox move sucessfully prior to installing CU7. I've found this site to also help troubleshoot http://blogs.technet.com/b/shahnawaz/archive/2014/05/29/part-ii-cut-over-migration.aspx

I followed step 10 but can't get the following powershell commands to work since it never gets to the migration.

Get-MigrationStatistics | fl
Get-Migrationuser –identity <userfailingmigration> | fl
Get-MigrationUserStatistics -id <userfailingmigration> | fl
Get-MigrationUserStatistics -id <userfailingmigration> -diagnostic | fl
Get-MigrationUserStatistics -id <userfailingmigration> -includereport | fl



I'm sure I'll have to open a microsoft case to get this resolved.




Page: [1]