• RSS
  • Twitter
  • FaceBook

Exchange Server Forums

Forums | Register | Login | My Profile | Inbox | RSS RSS icon | My Subscription | My Forums | Address Book | Member List | Search | FAQ | Ticket List | Log Out

Cannot Mount Exchange Database

Users viewing this topic: none

Logged in as: Guest
  Printable Version
All Forums >> [Microsoft Exchange 2010] >> High Availability >> Cannot Mount Exchange Database Page: [1]
Login
Message << Older Topic   Newer Topic >>
Cannot Mount Exchange Database - 20.Aug.2015 9:58:40 PM   
keegans

 

Posts: 1
Joined: 20.Aug.2015
Status: offline
We had some strong storms move through our area last night and took out power at alot of clients, among them is a client whose exchange database will no longer mount correctly after the server lost power.
OS is SBS 2011

First thing i did was run eseutil on the database using the /mh switch and it told me it had a dirty shutdown status. First thing i tried doing was copying the log files and the database out of the exchange directory and, after using /ml to verify the log files, i tried using eseutil on it. I ran it using the /r switch and it failed saying the database is corrupted. the specific command i used was: eseutil /R E00 /l "c:\exchangerecover3' /s "c:\exchangerecover3" /d "c:\exchangerecover3"

We have a good local backup (full) that ran the night before and several shadow copy backups in the previous versions. I have tried restoring the local backup that is stored on a NAS using windows server backup but it fails with:
Name: Microsoft Exchange Server\Microsoft Information Store\*servername*\*longstring of numbers*
Message: The application extension plug-in failed to perform the post recovery steps for the component

Next I tried copying a previous version of the folder and then backed up the entire database folder, and replaced it with that previous version and that didn't work either. I made a third copy of the original database and set it aside in a folder and ran eseutil /p on it as a last resort, but i haven't tried anything with that yet, so its just sitting there.

Does anyone know of anyway to get this going? I think that my best option is going to be that windows backup, it took a full successful backup of everything, application, system state, files, bare metal, etc... I would think there is some other way to get it restored but I can't find that error on google, and the results I've found so far tell me to do what I already tried, which is:
1. click recovery in wsb
2. this server
3. next
4. select date and time
5. next
6. applications
7. next
8. exchange
9. next
10. restore to original location
11. start backup ( i may have missed some steps as that was from memory but you get the idea)

I told exchange to allow the database to be overwritten during a recovery. And I have also tried it with roll-foward turned on or off. I also have circular logging enabled due to storage constraints on the server, but each backup is a full one and not a differential or incremental, so I wouldn't think that would be a problem.


____________________________________________


I ran that eseutil /r command in the live database folder on the database that i recovered, figured it wouldn't really matter since i already restored to it. It came back with a clean shutdown status after running the recovery when i checked it with /mh. I went to exchange and tried mounting it and it failed with the below message from EMC (i should also add that after it fails to mount it goes back to a dirty shutdown state) (also I checked the logs using /ml and they all retunred an ok):

--------------------------------------------------------
Microsoft Exchange Error
--------------------------------------------------------
Failed to mount database 'Mailbox Database'.

Mailbox Database
Failed
Error:
Couldn't mount the database that you specified. Specified database: Mailbox Database; Error code: An Active Manager operation failed with a transient error. Please retry the operation. Error: Database action failed with transient error. Error: A transient error occurred during a database operation. Error: MapiExceptionJetErrorLogWriteFail: Unable to mount database. (hr=0x80004005, ec=-510)
[Database: Mailbox Database, Server: servername.domain.local].

An Active Manager operation failed with a transient error. Please retry the operation. Error: Database action failed with transient error. Error: A transient error occurred during a database operation. Error: MapiExceptionJetErrorLogWriteFail: Unable to mount database. (hr=0x80004005, ec=-510)
[Database: Mailbox Database, Server: servername.domain.local]

An Active Manager operation failed with a transient error. Please retry the operation. Error: MapiExceptionJetErrorLogWriteFail: Unable to mount database. (hr=0x80004005, ec=-510)
[Server: servername.domain.local]

MapiExceptionJetErrorLogWriteFail: Unable to mount database. (hr=0x80004005, ec=-510)





--------------------------------------------------------
OK
--------------------------------------------------------
Post #: 1
RE: Cannot Mount Exchange Database - 21.Aug.2015 3:49:04 AM   
ronniepaul

 

Posts: 86
Joined: 2.Dec.2014
Status: offline
Hi..

As you have tried eseutil, now i would like to recommend you Exchange Recovery software with which you can easily repair and directly mount exchange database to new server.

Read More at: http://www.exchangerecover.com/recovery-tool-for-exchange.html

< Message edited by ronniepaul -- 21.Aug.2015 4:11:34 AM >

(in reply to keegans)
Post #: 2
RE: Cannot Mount Exchange Database - 16.Nov.2015 1:00:41 AM   
irene234

 

Posts: 24
Joined: 27.Nov.2014
Status: offline
You people can actually try using the “Ahsay” software for taking backup and restoring too. I am taking their service from long time and really satisfied using this software. If you want more just go to their website and try using their service. For more info leaving a link below:http://www.ahsay.com/jsp/en/home/index.jsp?pageContentKey=ahsay_products_overview
Post #: 3
RE: Cannot Mount Exchange Database - 7.Aug.2016 10:33:30 AM   
s_patrick

 

Posts: 22
Joined: 7.Aug.2016
Status: offline
Hi,
Generally, this problem appears due to issue in log files. I am just sharing a easy solution here that worked for me in the similar problem: http://bit.do/cbrm7

This tool successfully fixed and mounted the information store databases back to server. This application supports to all versions of MS Exchange server and has a free trial version also that can be run to test its features and functionality.

- Patrick

(in reply to irene234)
Post #: 4

Page:   [1] << Older Topic    Newer Topic >>
All Forums >> [Microsoft Exchange 2010] >> High Availability >> Cannot Mount Exchange Database Page: [1]
Jump to:

New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Follow TechGenix on Twitter