• RSS
  • Twitter
  • FaceBook

Exchange Server Forums

Forums | Register | Login | My Profile | Inbox | RSS RSS icon | My Subscription | My Forums | Address Book | Member List | Search | FAQ | Ticket List | Log Out

senderID agent seems to not work

Users viewing this topic: none

Logged in as: Guest
  Printable Version
All Forums >> [Microsoft Exchange 2013] >> Message Routing >> senderID agent seems to not work Page: [1]
Login
Message << Older Topic   Newer Topic >>
senderID agent seems to not work - 2.Mar.2016 3:39:46 PM   
extrem1st

 

Posts: 3
Joined: 2.Mar.2016
Status: offline
I have two Exch 2013 servers running CU11 in a DAG. I've enabled senderID, I've setup SPF records for my domains on my public DNS, and the "test-senderid" cmdlet correctly pulls a PASS or FAIL based on what IP I give it.

senderID is set to REJECT as is the temperroraction optional setting.

If I get on an external network and telnet to my mail server at port 25, then type ehlo, mail from:validuser@mydomain.com, I immediately get a Sender Ok and it accepts my message. Except it should FAIL, as my external IP address isn't in the SPF record.

Any ideas on where to look?
Post #: 1
RE: senderID agent seems to not work - 25.Mar.2016 2:44:08 PM   
HwSystems

 

Posts: 2
Joined: 25.Mar.2016
Status: offline
Hi extrem1st,
Did you make a complete transaction using Telnet with DATA and sending the message body? I ask that because I never seen a SMTP server checking SPF record at the MAILFROM command. Normally it check if the recipient specified by RCPT TO is valid before doing DNS intensive lookup

(in reply to extrem1st)
Post #: 2

Page:   [1] << Older Topic    Newer Topic >>
All Forums >> [Microsoft Exchange 2013] >> Message Routing >> senderID agent seems to not work Page: [1]
Jump to:

New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Follow TechGenix on Twitter