• RSS
  • Twitter
  • FaceBook

Exchange Server Forums

Forums | Register | Login | My Profile | Inbox | RSS RSS icon | My Subscription | My Forums | Address Book | Member List | Search | FAQ | Ticket List | Log Out

Mail freezes in the smtp queue

Users viewing this topic: none

Logged in as: Guest
  Printable Version
All Forums >> [Microsoft Exchange 2003] >> Message Routing >> Mail freezes in the smtp queue Page: [1]
Login
Message << Older Topic   Newer Topic >>
Mail freezes in the smtp queue - 9.Apr.2005 10:22:00 AM   
psynaut

 

Posts: 2
Joined: 9.Apr.2005
From: Stockholm
Status: offline
Hi!
I have a site where my mail freezes in the smtp queue, its a Exchange 2003 Ent. Published behind a Isa 2004
I am not sure if this is a exchange or isa problem.

But If I restart my exchange 2003 server or smtp service the mail sends away and there is nothing in queue, but then after a day or some hours or a week the queue freezes again

Anyone have any ideas?

Regards

/Tommy
Post #: 1
RE: Mail freezes in the smtp queue - 26.Apr.2005 4:21:00 PM   
Adrian_FD

 

Posts: 1
Joined: 26.Apr.2005
From: Texas
Status: offline
Tommy,

Are you still experiencing the same problem? I'm running an Exchange 2003 server and am having this exact problem. Question...have you recently done an offline defrag of the mailbox store? The problem I had began after I did this offline defrag. I don't see why this would cause a problem, but it seems to have. Have you come up with any suggestions? Thanks.

(in reply to psynaut)
Post #: 2
RE: Mail freezes in the smtp queue - 26.Apr.2005 6:57:00 PM   
jd_bouque

 

Posts: 12
Joined: 27.Jul.2004
From: Dartmouth
Status: offline
I had this same problem and it occurred after installing KB894549.

I removed it and the problem did not go away and only got worse over a day or two. I ended up on the phone with Microsoft when I was unable to send or receive anything. After 4 hours we ended up reinstalling Exchange.

They never determined what the problem was and denied that KB894549 could have had anything to do with it.

Something I also noticed was when the queue would really fill up, it seemed to be with old mail because after I had everybody off the system "new" mail would come back into the queue after we deleted it all.

Very strange.

(in reply to psynaut)
Post #: 3
RE: Mail freezes in the smtp queue - 28.Apr.2005 4:21:00 PM   
rickcthomas

 

Posts: 1
Joined: 28.Apr.2005
From: Texas
Status: offline
This problem started with us yesterday. Specifically, an individual site in the smtp virtual server queue freezes and it takes a reboot for them to finally send.

We haven't done an offline defrag nor have we installed KB894549. Basically, it appears that the our exchange 2k3 server establishes a communication session with the other site server which responds and be begin sending data. For what ever reason the other site's server sends a second response then they seem to get out of sync or something and the queue freezes in the active state. It appears that the reboot kills that frozen connection, re-establishes a new connection that works fine.

I'm going to try and contact the site involved and see if they will help try and figure out what is going on. I believe this "the two servers getting out of sync during their SMTP communication session" problem is the cause of intermittent complaints from fols out in the world who have gotten SMTP NDRs when trying to email us.

Just thought I'd pass on the info for what it is worth.

Rick

(in reply to psynaut)
Post #: 4
RE: Mail freezes in the smtp queue - 16.May2005 3:55:00 PM   
Guest
Any new developments on this issue? We're experiencing it exactly as described. A reboot fixes the problem, but I'm getting tired of rebooting the server every 2-3 days.

(in reply to psynaut)
  Post #: 5
RE: Mail freezes in the smtp queue - 27.May2005 9:16:00 AM   
robdog1

 

Posts: 5
Joined: 24.May2005
From: Wilmington, DE
Status: offline
We got our mail flowing.....

Our solution was the Symantec deal. We went into Client Security (the configurator thing) and disabled INTERNET E-MAIL AUTO-PROTECT. Mail started flowing. Where we came up with this solution is that since e-mail flowed right at a reboot then started to stop, we assumed that it was the sequence of services starting up that broke exchange and that there was some conflicting service. Well, we were right and it got it working.....

The question is though, why can it send it to a non-exchange SMTP server with no problem?! Microsoft mysteries......

good luck...If disabling the auto-protect does not work, try just shutting down the Symantec service(s) instead of just the one auto-protect. Thats where we started and narrowed it down from there.

(in reply to psynaut)
Post #: 6
RE: Mail freezes in the smtp queue - 27.May2005 9:30:00 AM   
robdog1

 

Posts: 5
Joined: 24.May2005
From: Wilmington, DE
Status: offline
http://service1.symantec.com/SUPPORT/ent-security.nsf/docid/2004062508305148?OpenDocument&src=ent_hot&dtype=corp&prod=Symantec%20AntiVirus%20Corporate%20Edition&ver=9.0&tpre=

(in reply to psynaut)
Post #: 7
RE: Mail freezes in the smtp queue - 12.Jun.2005 4:22:00 AM   
Guest
thanks robdog1...don't understand why i was just getting frozen on hotmail.com and none of the other mega-free email hosts but the symantec av seemed to be the problem. [Big Grin]

(in reply to psynaut)
  Post #: 8

Page:   [1] << Older Topic    Newer Topic >>
All Forums >> [Microsoft Exchange 2003] >> Message Routing >> Mail freezes in the smtp queue Page: [1]
Jump to:

New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Follow TechGenix on Twitter