• RSS
  • Twitter
  • FaceBook

Exchange Server Forums

Forums | Register | Login | My Profile | Inbox | RSS RSS icon | My Subscription | My Forums | Address Book | Member List | Search | FAQ | Ticket List | Log Out

Exchange Performance is so slow, only 2k users!

Users viewing this topic: none

Logged in as: Guest
  Printable Version
All Forums >> [Microsoft Exchange 5.5] >> General >> Exchange Performance is so slow, only 2k users! Page: [1]
Login
Message << Older Topic   Newer Topic >>
Exchange Performance is so slow, only 2k users! - 16.Aug.2000 5:33:00 PM   
KoolKeith

 

Posts: 4
Joined: 16.Aug.2000
From: phoenix
Status: offline
We have a 4 proccesors server with 2 gigs of ram, and plenty of hard drive space. It is using dual-fiber cabling. We have around 2000 users. When you try and open up e-mails or send them there is a 10-12 seconed delay. I have run performance monitor to try and determine the bottle neck. Utilizations is never above 40% for cpu or network. Does anyone have any ideas on what I could do to determine the bottle neck?
Post #: 1
RE: Exchange Performance is so slow, only 2k users! - 17.Aug.2000 11:14:00 AM   
Lorna

 

Posts: 199
Joined: 9.Jun.2000
From: North America
Status: offline
How large is your information store? Is performance the same if you use Outlook at the server and open messages?

(in reply to KoolKeith)
Post #: 2
RE: Exchange Performance is so slow, only 2k users! - 17.Aug.2000 12:47:00 PM   
KoolKeith

 

Posts: 4
Joined: 16.Aug.2000
From: phoenix
Status: offline
It is 35 gigs. We have not installed office on any of our servers due to "standards"
I have noticed that it seems slow only during high usage times, like early in the morning, but running performance monitor, it doesnt even put a very big dent in the systems resources.

(in reply to KoolKeith)
Post #: 3
RE: Exchange Performance is so slow, only 2k users! - 18.Aug.2000 9:33:00 AM   
evetslp

 

Posts: 26
Joined: 5.Jun.2000
Status: offline
This probably has nothing to do with your problem, but I personally would break that server in half. 35 GB is alot to manage on one server (especially in the event of online/offline backups/restores). It sounds like you have the proper hardware for that kind of store, but it still seems like alot for one server when managing it is concerned.

(in reply to KoolKeith)
Post #: 4
RE: Exchange Performance is so slow, only 2k users! - 18.Aug.2000 10:03:00 AM   
turtons

 

Posts: 2
Joined: 18.Aug.2000
From: Wycombe, Bucks, UK
Status: offline
KoolKeith!;-)
What is your exchange server PDC/BDC or member server.
Also are your SP3 or before.
If you are SP3 re-run optimizer and reboot
Also make your pagefile size twice the computer memory + 100mb.
Failing that there are reference Technet articles on slow Outlook performance, you can make registry hacks to change the protocol order.
Of course it might be infrastructure -WINS related or DNS, try using IP addresses only to reference your Exchange server..
Have fun..


(in reply to KoolKeith)
Post #: 5
RE: Exchange Performance is so slow, only 2k users! - 21.Aug.2000 12:20:00 PM   
KoolKeith

 

Posts: 4
Joined: 16.Aug.2000
From: phoenix
Status: offline
I am running sp5 on the exchange server. The exchange server is also configured as a BDC. So I should make a 3 gig pagefile?

(in reply to KoolKeith)
Post #: 6
RE: Exchange Performance is so slow, only 2k users! - 21.Aug.2000 1:59:00 PM   
Russ

 

Posts: 181
Joined: 26.Apr.2001
Status: offline
tutons' recommendation sounds a little extreme for the page file. I was taught physical RAM plus 175 MB. Others will say RAM plus 12 for NT and another 100 for Exchange.
He did have another good idea, that it might be some name resolution problem. Create a HOSTS file on one of the clients pointing to Exchange (remember to save it with no extension!). If this client's performance improves dramatically, you will have narrowed down the problem.

(in reply to KoolKeith)
Post #: 7
RE: Exchange Performance is so slow, only 2k users! - 21.Aug.2000 5:34:00 PM   
storcy

 

Posts: 13
Joined: 17.Aug.2000
From: England
Status: offline
Surely you mean an LMHOSTS file Russ? I believe these are parsed first (provided it is preloaded by adding the #PRE statement). The correct syntax if my memory serves me is:
ipaddress netbiosservername #PRE #DOM :Domain
And again remember to remove the .SAM from the name. A quick NBTSTAT -R at the command prompt to reload the NetBIOS cache, and Bob's yer uncle.
Also, you said the server is a BDC. If its the sole BDC it will likely take the brunt of the early morning logons thus increasing it's workload? One more thing, on reply to Turtons mail you stated SP5 is on the server. I think he meant Exchange Service pack 3 (entirely different to NT SP5)

[This message has been edited by storcy (edited 08-21-2000).]


(in reply to KoolKeith)
Post #: 8
RE: Exchange Performance is so slow, only 2k users! - 22.Aug.2000 2:23:00 PM   
Guest
I have been also running some other things in performance monitor that i havnt noticed before. Check dis out!
Outbound bytes is 100% utilized
LAN Reiceved bytes is around 90 % utilized
Well that leads me to belive that we better network card. Could this be a correct asumption?

(in reply to KoolKeith)
  Post #: 9
RE: Exchange Performance is so slow, only 2k users! - 23.Aug.2000 2:40:00 AM   
Anders

 

Posts: 10
Joined: 11.Jul.2000
From: Ireland
Status: offline
I have noticed that sometimes you can experiance trouble with network-cards inproperly setup, Run the card on 100Mbit and Full Duplex, also check that the switch is hardcoded the same way, don't run it on Auto, if this is the problem you will also get a better performance at the backup situation. The Autopart (as far as I know) on the switch is something that has to be changed to 100/Full when you run Exchange, the performance is 100% better.

(in reply to KoolKeith)
Post #: 10
RE: Exchange Performance is so slow, only 2k users! - 23.Aug.2000 4:20:00 PM   
KoolKeith

 

Posts: 4
Joined: 16.Aug.2000
From: phoenix
Status: offline
I am changing out the nic cards, the switch is not set on auto. I hoping that putting in another nic

(in reply to KoolKeith)
Post #: 11

Page:   [1] << Older Topic    Newer Topic >>
All Forums >> [Microsoft Exchange 5.5] >> General >> Exchange Performance is so slow, only 2k users! Page: [1]
Jump to:

New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Follow TechGenix on Twitter