• RSS
  • Twitter
  • FaceBook

Exchange Server Forums

Forums | Register | Login | My Profile | Inbox | RSS RSS icon | My Subscription | My Forums | Address Book | Member List | Search | FAQ | Ticket List | Log Out

unable to receive external mail for secondary domain

Users viewing this topic: none

Logged in as: Guest
  Printable Version
All Forums >> [Microsoft Exchange 2003] >> Exchange 2003 SBS >> unable to receive external mail for secondary domain Page: [1]
Login
Message << Older Topic   Newer Topic >>
unable to receive external mail for secondary domain - 11.Apr.2011 11:33:12 AM   
augwoo

 

Posts: 4
Joined: 11.Apr.2011
Status: offline
Hi Guys,

Hoping someone can help. I have a site which runs SBS 2003. It is set up to receive email on two domains: @domain1.com and @domain2.com it's been running happily for 3 months like this.

Today I had a request to create a new alias for one of the users on domain2.com. In Active directory users and computers, I added the smtp address hello@domain2.com in the users email address tab.

Since doing that all external mail to the entire @domain2.com mail has stopped working.

When an external mail is sent, it is returned with the message:Error 550 unknown user.

Internally, sending mail from @domain1.com to @domain2.com works fine.

I telneted in on 25, and manually sent an email from @domain1.com to @domain2.com, but figured this is the same thing as testing by sending a mail from outlook from one internal domain to another.

NOthing else has changed as far as I'm aware t stop this from working!

I have tried removing @domain2.com from the default policy in server management, and then adding it in again, but this still does not make it work again.

Any help greatly received! As the client is getting a bit antsy now!
Post #: 1
RE: unable to receive external mail for secondary domain - 11.Apr.2011 1:22:29 PM   
uemurad

 

Posts: 8232
Joined: 7.Jan.2004
From: California, USA
Status: offline
What recipient filter(s) do you have in place?

Does your inbound mail go directly to Exchange, or does some other system or software analyze messages first?

How long after you added the alias did you attempt sending it a message?

_____________________________

Regards,

Dean T. Uemura
Microsoft MVP - Exchange (2007-2011)
exchangeguy.blogspot.com
uemurad@yahoo.com

(in reply to augwoo)
Post #: 2
RE: unable to receive external mail for secondary domain - 11.Apr.2011 1:47:45 PM   
augwoo

 

Posts: 4
Joined: 11.Apr.2011
Status: offline
it goes straight to exchange, no other scanning, and no recipient filters in place.

I noticed that mail stopped being able to be sent in from external about 10 mins after trying to add an alias to one user.

I'm in the process of trying to remove the second domain from the recipient policy, reboot and add it in again.

(in reply to augwoo)
Post #: 3
RE: unable to receive external mail for secondary domain - 11.Apr.2011 2:09:00 PM   
augwoo

 

Posts: 4
Joined: 11.Apr.2011
Status: offline
I have removed the recipient policy, rebooted and added it again. but still no joy.

(in reply to augwoo)
Post #: 4
RE: unable to receive external mail for secondary domain - 11.Apr.2011 3:19:49 PM   
uemurad

 

Posts: 8232
Joined: 7.Jan.2004
From: California, USA
Status: offline
The Recipient Policy only stamps your user objects. It would have no effect over whether an alias works unless you are changing the status of whether Exchange is acting authoritatively for that domain.

Test your configuration from the outside. Get to a computer connected to the Internet but completely outside your network. Perform a public DNS lookup (NSLookup works for this) of domain2.com to see if the MX record is pointing to the correct location. Next, use Telnet to create an inbound message to the new alias address.

If you are unable to perform these tests, send me a private message with the alias SMTP address in question and I can test it from an outside system.

_____________________________

Regards,

Dean T. Uemura
Microsoft MVP - Exchange (2007-2011)
exchangeguy.blogspot.com
uemurad@yahoo.com

(in reply to augwoo)
Post #: 5
RE: unable to receive external mail for secondary domain - 11.Apr.2011 4:44:07 PM   
augwoo

 

Posts: 4
Joined: 11.Apr.2011
Status: offline
thanks for your help, all sorted! the mx records had been messed up. The domain was registered by a member of staff, and the mx records were set by me a few months back. At exactly the time I was trying to set up a new alias this morning, the same user who had registered the domain, decided they wanted hosting for that domain, so activated it, which set up mail and automatically changed the mx records to point at the hosts email servers. They neglected to tell me this, even though they told me their mail had stopped working.

thanks for your help. now i've changed the mx records back, got to wait for them all to propogate properly, at the moment I can send mail from some webmail (eg yahoo and facebook) but google apps is still looking at the old cached mx records.

(in reply to augwoo)
Post #: 6

Page:   [1] << Older Topic    Newer Topic >>
All Forums >> [Microsoft Exchange 2003] >> Exchange 2003 SBS >> unable to receive external mail for secondary domain Page: [1]
Jump to:

New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Follow TechGenix on Twitter